Tap/DHCP interface not coming up after restart. VMs won’t get private IP addresses

I’m running all my quantum processes on the controller. Something odd, I don’t know if this is a bug or what. When my controller restarted. The gateway interfaces for tenant subnets do not come up, also the interface that the dnsmasq process serves up ip addresses on, doesn’t come up either.

So in my case I have created a 10.5.5.0/24 subnet in a tenant. And I set the gateway to 10.5.5.1/24. When you do this it will create two tap interfaces. One will be the gateway and one will be an interface that the dnsmasq process serves up ip addresses on. When I restarted the controller. Those interfaces do NOT come back up. I had to bring them up manually with the command you will see below.

Image

If you want to see what interfaces are up. Do an “ifconfig” at the command line.

If you want to see what interfaces exist, but aren’t up, do an “ifconfig -a” Again you might see the gateway and dhcp interface that you created…..but they aren’t up. You gotta bring them up yourself….

Advertisements

One thought on “Tap/DHCP interface not coming up after restart. VMs won’t get private IP addresses

  1. Pingback: Quantum OVS, gre tunnel, vlan…….weirdness | visualne

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s